Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Window washer motor
#1
Hi guys,

my window washer motor failed a while ago. I disconnected it and ordered a new one from Ed (the same as DMC USA from the picture).
The one I got is rather different from the one that was on the DeLorean.
In the way that it doesn't fit on the reservoir.
Do you guys know why there is a difference between these motors.
I have #1879.
Sorry for the blurry photo's.


Attached Files Image(s)
       
Reply
#2
As i remember you have to remove the original rubber grommet from the bottle then you push the washer pump adaptor in to the bottle hole and screw the motor up, this will crush the rubber and seal bottle and motor if that makes sense.
Reply
#3
Smile 
Thank you,

that explains it. It's a different one then. I'll keep the old one, maybe I can still fix it. The motor runs, the blades that pump are just totally gone. Vanished. Very weird.
Reply
#4
Ok,

I found out what the problem was.
The old motor excists out of 4 parts. The new one only 2.
Whilst trying to remove the rubber, one part descrewed, on wich I could screw the new one.
Reply
#5
they are renowned for failing as they get clogged up with water and mud in the part of the body they sit in.
Claire  - DOC-UK Treasurer
1981/W DeLorean DMC-12 'Flopsy' - #2292 - resting due to block rot 
1989/G Vauxhall Cavalier 1.6L 5dr "Guinney" -
1995/N Renault Espace RT Alize 2.1TD "Jaffa the Bus"
DOC170
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)